In my previous coverage on our TrueNAS CORE build, I got the entire system together but I skipped talking about how I hooked up the 8 SATA drives to our mATX motherboard. I had a plan when going in, but sometimes things don’t go the way you had planned. In fact, my problems went even beyond that. So today I want to run through what went wrong with our original plan and then our backup plan as well and go over what I ended up doing. When getting things running I also ended up adding an upgrade as well. So let's get up to date on the TrueNAS CORE servers current setup and why!

Title: Project Data Hoarder – TrueNAS CORE Build Part 5 – Figuring out problems and upgrades

Written by: Wes Compton

Build Sponsors/Supporters: Silverstone - Western Digital - CrucialFSP

Amazon Affiliate link: Storage Drives – OS Drive

Links to the rest of the project: Part 1 – Part 2 – Part 3Part 4 – Part 5

 

Storage Issues!

So when I picked out the motherboard for this build the storage options needed to be able to hook up all eight SATA hard drives meant I had to skip over using a more modern motherboard/CPU for the X299 Micro. That isn’t a jab at the EVGA board, I really do like it. But if I had my way I would have gone with a Ryzen or 115X Intel option both for power consumption and performance. BUT the X299 Micro was the only board I had on hand that had a way to handle 8 SATA drives and was mATX or ITX. The plan was to use four of the six SATA ports then use the built-in U.2 port with a U.2 to Mini-SAS SFF-8087 cable. Silverstone was nice enough to send over two SATA to Mini-SAS SFF-8087 cables for this setup and the SFF-8087 to U.2 cable as well. The 8087 to SATA cables have a white sleeving and inside the SATA cables are surprisingly thin compared to cables like this that I’ve used with RAID cards in the past which is good because the Silverstone RM21-308 case is very tight.

image 18

 

image 19

 

image 20

 

image 21

 

The SATA to Mini-SAS SFF-8087 setup wasn’t going to be a problem of course. That is standard. It was taking advantage of the U.2 port by using an SFF-8643 to SFF-8087 cable that was more of a worry. Once I found the cable from Silverstone I thought I was all set and they sent one of their CPS06’s over. It is a simple cable with the same Mini SAS connection that the backplane on the case requires and on the other end a female U.2 port to fit up with our motherboard. I was more worried that by using the U.2 on our motherboard that we might lose our M.2 slot or something else. But X299 has more than enough lanes and that wasn’t an issue. So when I built everything this is the setup I went with.

image 14

 

image 15

 

image 16

 

image 17

 

So what went wrong? Well, when planning all of this out I was more worried about getting the correct connections and making sure the board itself would support the U.2 being used without it turning anything we needed off. Well when I got everything set up, I couldn’t get things working at all. I did have a backup plan, however. I have a few raid cards sitting around from some of our past storage builds for our LAN events, specifically an old LSI MegaRAID 9260-8i. I would just need a few new cables to get things up and running. Specifically, two SFF-8087 to SFF-8087 cables and Silverstone once again came in clutch and sent two over. After waiting for those to come in I hooked everything up and our drives still weren’t showing up in TrueNAS. I had to get a monitor down by our rack and find a GPU that would fit as well. X299 doesn’t have onboard video at all so I wedged in a video card temporarily. With that up and running I made sure there wasn’t an issue in our BIOS then I figured the issue out. Because my 9260-8i was running as a raid card, I needed to get into the raid cards BIOS and set things up. BUT with our TrueNAS setup, the main goal was to try out ZFS, setting up a full raid here would prevent that altogether. So I went through and set up each hard drive individually on the raid card so that it would pass them on to TrueNAS properly. Only after going through all of that trouble did I find an even bigger issue. It did work and all of the drives showed up on TrueNAS, but each was capped at 2TB, not their real 8TB capacity. As it turns out, our MegaRAID 9260-8i was an early model that didn’t support larger hard drives. I had to scrap all of this again and start over for a third time!

image 1

 

image 2

 

image 3

 

image 4

 

Well after both the plan and the backup plan fell through I spent some time looking at my options. I didn’t want to spend much money. I was looking at basic PCI to SATA options where I could just use the SATA to SFF-8087 cables that I already had. But with it being a server, I decided to go back to a proper RAID card, only this time I wanted to get one and reflash it to run in IT mode. This disables the main RAID functionality and passes the drives on just like I need for ZFS. There are a few great videos on how to do this on YouTube. I also ran into a great video on what some of the different card options do and what you need depending on if you are planning on hooking hard drives or SSDs up. I would highly recommend anyone wondering what card they should get to check it out. The guy who makes the video also sells a lot of the cards on eBay, some even pre-flashed into IT mode as well. HERE is a link to that video. I ended up going with the Dell H310 which is a variation on the LSI 9211-8i and the one I picked up came already in IT Mode which saved me some trouble as well but ended up being $65 shipped. I could have gone with a cheaper option, but long term the H310 should hold up better and have fewer potential issues.

image 5

 

image 6

 

Hooking things up went quickly, The H310 has its SFF-8087 ports on the end which work better with the 2u case and I already had the two SFF-8087 to SFF-8087 cables that Silverstone sent. While there were big delays between each of the issues I ran into once you figure in research time and waiting for things to ship. But the H310 worked right away when I hooked it up, no additional configuration was needed and all of our 8TB drives finally showed up.

image 7

 

 

Log in to comment

We have 1221 guests and one member online

supportus